Страница 1 из 1

Ошибка при запуске теста

СообщениеДобавлено: 04 фев 2019, 13:45
netraider
Здравствуйте.
У меня при запуске конфигурации теста однократно проскакивает ошибка:
{Обработка.TPC_1C_GILV.Форма.Форма.Форма(482)}: Ошибка при вызове конструктора (COMОбъект): -2147221005(0x800401F3): Недопустимая строка с указанием класса
Во время запуска и работы теста ошибок нет. Платформа 8.3.13.1644 (х64) + SQL Server 2017 со всеми обновлениями. Ось Windows Server 2016 Standard. Платформа и сервер на одном компе, все свежеустановленное.

Re: Ошибка при запуске теста

СообщениеДобавлено: 04 фев 2019, 13:47
Гилёв Вячеслав
но тест то проходит?

Re: Ошибка при запуске теста

СообщениеДобавлено: 04 фев 2019, 14:44
netraider
Проходит, но подозрительно мало баллов набирает. Сервер корпоративного класса, 4 процессора Intel(R) Xeon(R) Gold 6154 CPU @ 3.00GHz (по 18 ядер в каждом), 1,5 терабайта оперативки, SSD диски Intel(R) Optane(tm) SSD DC P4800X. Вся эта система набирает 38 баллов!!!! На сервере ничего кроме 1С и SQL нет. Просто подозрительно мало. Вот и подозреваю, что из за этой ошибки тест некорректно работает.

Re: Ошибка при запуске теста

СообщениеДобавлено: 04 фев 2019, 17:41
Гилёв Вячеслав
у нас хороший тест, проверенный 10 годами если хотите
ошибка не влияет
ищи проблему в сервере или среде

Re: Ошибка при запуске теста

СообщениеДобавлено: 05 фев 2019, 10:17
netraider
Да я не подвергаю сомнению ваш тест)
Кстати, сегодня запустил файловый вариант теста. И что интересно, в нем не появляется ошибка при запуске и набирает больше 70 баллов. Видимо, дело в SQL 2017

Re: Ошибка при запуске теста

СообщениеДобавлено: 05 фев 2019, 15:11
Гилёв Вячеслав
гадать последнее дело
там ошибка COM, не происходит подключение к ком-объекту соединения с сервером 1С для опроса параметров, на тест это не влияет, скуль не причем

Re: Ошибка при запуске теста

СообщениеДобавлено: 08 июн 2020, 17:43
goto
мне помогло это:

Код: выделить все
regsvr32 "C:\Program Files (x86)\1cv8\8.3.15.1747\bin\comcntr.dll"